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1. Overview

ARMSim# is a desktop application running in a Windows environment. It allows users to
simulate the execution of ARM assembly language programs on a system based on the
ARM7TDMI processor. ARMSim# includes both an assembler and a linker; when a file is
loaded, the simulator automatically assembles and links the program. ARMSim# also
provides features not often found in similar applications. They enable users both to
debug ARM assembly programs and to monitor the state of the system while a program
executes. The monitoring information includes both cache states and clock cycles con-
sumed.

The purpose of this user guide is to explain how to use the tools and views! provided by
ARMSim#. Therefore, the scope of the document has been limited to the features of the
simulator. It does not cover ARM assembly programming or computer architecture.
Users who are unfamiliar with these topics should consult other material, some of which
is listed in the references.
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The topics in this document have been organized to provide a step-by-step introduction
to ARMSim#, including the extra features regarding I/O instructions, based on custom
SWI codes, and plug-ins. The table of contents below summarizes the items described.

1. In this document, a view is a window displayed by the ARMSim# simulator that shows the state of some
aspect of the program being run.
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Sections 2 and 3 begin with the features of the simulator and explain how to customize its layout. Sec-
tion 4 describes the most commonly used debugging features and views. Sections 5 and 6 conclude by
detailing additional debugging features, views and performance monitoring tools. Section 8 includes
details about the extra features of ARMSim#, namely the I/O instructions built on custom SWI codes
(implemented as as external Plug-in). Section 9 introduces the Plug-in feature, with detailed examples of
use based on the currently available modules.

2. Features

The ARMSim# toolbar and views give the user access to a variety of tools to debug and monitor ARM
assembly language programs. The following sections describe the controls provided by the toolbar and
the information displayed in the views.

2.1 Toolbar

The ARMSim# toolbar provides easy access to many of the debugging features of the simulator, espe-
cially those features that allow the user to control the execution of a program. The functions of the but-
tons on the toolbar are summarized in Table 1.

Table 1. Toolbar Buttons.

The Step Into button causes the simulator to execute the highlighted instruction and move to
the next instruction in the program. If the highlighted instruction is a subroutine call (BL or BX
instruction) then the next highlighted instruction will be the first instruction of the subroutine.

I|}ﬁ|

The Step Over button causes the simulator to execute the highlighted instruction and move to
the next instruction in the current subroutine. If the highlighted instruction is a subroutine call
(BL or BX instruction) then the program is run until the subroutine returns. Thus, unless a
breakpoint is encountered, the next highlighted instruction will be at the return point from the
subroutine call.

+
Il

The Stop button causes the simulator to stop the execution of the program.

The Continue button causes the simulator to run the program until it encounters a breakpoint,
an SWI 0x11 instruction (end of execution), or a run-time error.

The Restart button causes the simulator to start the execution of the program from the begin-
ning.

The Reload button causes the simulator to load a new version of the program file from the
hard drive and start the execution of the program from the beginning.

o | [=] = | =

2.2 Views

The ARMSim# views display the simulator’s output and the contents of the system’s storage. ARMSim#
provides several views, which are summarized in Table 2.
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Table 2. ARMSim# Views

Code View

It displays the assembly language instructions of the program that is cur-
rently open. This view is always visible and cannot be closed.

Registers View

It displays the contents of the 16 general-purpose user registers available in
the ARM processor, as well as the status of the Current Program Status Reg-
ister (CPSR) and the condition code flags. The contents of the registers can
be displayed in hexadecimal, unsigned decimal, or signed decimal formats.
Additionally the contents of the Vector Floating Point Coprocessor (VFP)
registers can be displayed. They include the overlapped Single Precision
Registers (s0-s31) and the Double Precision Floating Point Registers (d0-
di15).

Output View: Console

It displays any automatic success and error messages produced by the sim-
ulator.

Output View: It displays any text printed to standard output, Stdout.

Stdin/Stdout/Stderr

Stack View It displays the contents of the system stack. In this view, the top word in the
stack is highlighted.

Watch View It displays the values of variables that the user has added to the watch list,

that is, the list of variables that the user wishes to monitor during the execu-
tion of a program.

Cache Views

They display the contents of the L1 cache. This cache can consist of either a
unified data and instruction cache, displayed in the Unified Cache View, or
separate data and instruction caches, displayed in the Data Cache and
Instruction Cache Views, respectively, depending on the cache properties
selected by the user.

Board Controls View

It displays the user interfaces of any loaded plug-ins. If no plug-ins were
loaded at application start, this view is disabled.

Memory View

It displays the contents of main memory, as 8-bit, 16-bit, or 32-bit words.
There can be multiple memory views, each displaying a different region of
memory.

3. Setting up the Simulator

The appearance of ARMSim#, including the location, font, and colour of the views, can be customized to
suit the user’s preferences. When the simulator is closed, the settings are remembered for next time the
user starts up ARMSim#. The following sections describe how to customize ARMSim#’s appearance.

3.1 Docking Windows

All of the views described in section 2.2, except the Code View, appear in docking windows (see Figure
1). Each window can be docked along any side of the application window, or it can float above the appli-
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cation window. In addition, each docking window can be displayed or hidden, and each displayed win-
dow has an auto-hide option.

To move a docking window, click the title bar of the window, and drag the window to the desired loca-
tion. If multiple views have been stacked within a single docking window;, select the tab with the desired
view name from the tabs along the bottom of the docking window, click this tab, and drag it to the
desired location.

To toggle a docking window between the show and hide states, select the view name from the View
menu. Alternatively, to hide a docking window that is currently displayed, click the X in the top right
corner of the docking window. To toggle a docking window between the show and auto-hide modes,
click the pin in the top right corner.

File View Cache Debug Watch Help

ocked Window in : :

= Auto-hide Mode Floating Window
=]

g

% DutputView

i

-

Docked Window Use the pin to toggle between the snow and

auto-hide modes, and use the X to hide the view

i — \\ e —
|

Label Yalue

Use The tabs to select one
view from a stack of views

(5! wotchven T reccochevin |

Figure 1. Docking Windows

3.2 Board Controls View: the plug-ins and the SWI instructions

While ARMSim# can be used completely on its own, the extra features of plug-ins and I/O instructions
can be extremely useful. They have to be enabled explicitly even when installed at the same time. Plug-
ins (see below) are seen as configurable additions to provide extra functionality, normally as a graphical
view of I/O (e.g. a board with buttons and lights). One other very important extension is the use of pre-
selected SWI instructions to implement I/O functionalities, such as reading and writing from stan-
dardinput or output or files (see below).
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In order to enable these features. click on File and Preferences and then select the tab Plugins. The avail-
able modules as loaded in the ARMSim# directory are listed and need to be checked for enabling.

3.3 Fonts

To change the font, size, style, or colour of the text in a view, move the cursor into the view, click the right
mouse button, and select Font from the context menu. Then, make changes in the Font dialog box, and
click OK. To restore the original font settings, move the cursor into the view, click the right mouse but-
ton, and select Restore Defaults from the context menu. Note that Restore Defaults will also restore the
default background and highlight colours.

3.4 Colours

To change the background (highlight) colour in a view, move the cursor into the view, click the right
mouse button, and select Background Colour (Highlight Colour) from the context menu. Then, make
the changes in the Color dialog box, and click OK. To restore the original background and highlight
colours, move the cursor into the view, click the right mouse button, and select Restore Defaults from
the context menu. Note that Restore Defaults will also restore the default font settings.

The use of the highlight colour depends on context. For example, in the Code and Stack Views, it is used
as a background colour on the highlighted line, but in the Register and Cache Views, it is used as a text
colour for storage locations that have been written to.

4. Getting Started

Using ARMSim# to simulate the execution of a program on an ARM processor involves two activities—
actually running the program and observing the output. Sections 4.1 to 4.4 provide information on run-
ning programs with the simulator, while sections 4.5 and 4.6 describe two of the views available in the
simulator.

4.1 Creating a File

ARMSim# accepts both ARM assembly source files that use the Gnu Assembler (gas) syntax and ARM
object files generated by the Gnu tools provided with Cygwin or CodeSourcery. ARM assembly source
files can be created using any text editor (e.g. TextPad) and must be saved with a .s filename extension.
ARM object files can be generated from ARM assembly files or C source files and must be compiled
according to the instructions in the accompanying document on “C and ARM”. For details on ARM
assembly programming consult the references.

4.2 Opening and Loading a File

To open a file, select File > Load. Then navigate to the folder in which the file is stored and double-click
the file to be opened. When a file is opened, it is automatically assembled (if it is a source file) and
linked. If the assembly and linking processes are successful, the contents of the file appear in the
Code View with the first instruction in the _start (or main) subroutine highlighted. If the contents of the
file appear in the Code View, but the first instruction is not highlighted, one must check the Output
View for compiler errors (see section 6.3).

Notes:
¢ The file to be opened must be a source (.s) file or an object (.0) file.
¢ If the file to be opened does not appear in the directory listing in the dialog box, check to make
sure that the appropriate file type has been selected.
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¢ The source code cannot be edited in the Code View window, but must be changed in the original
text editor and then reloaded.
4.3 Running a Program

To run the program displayed in the Code View, select Debug > Run, or click the Continue button on
the toolbar (see Table 1). The program runs until the simulator encounters a breakpoint (see section 5.5
for an explanation of breakpoints) or an SWI 0x11 instruction (to exit the execution), or a fatal error.

4.4 Stopping a Program

To stop a program that is currently running, select Debug > Stop, or click the Stop button on the toolbar
(see Table 1). When the program has stopped, any storage locations in the Register, Cache, and Memory
Views that have been written to since the program started running are highlighted.

4.5 Code View

The Code View displays the assembly language instructions of the program that is currently active.
Next to each instruction, the simulator shows the memory address of the instruction and the binary rep-
resentation of the instruction, separated by a colon and displayed in hexadecimal format (see Figure 2).

« Mamu3ﬁlbmﬂ§MMhD]

000 :E3A01D4E ldr rl ,=STRING ~
0001004 :E59F220C ldr r2 ,=SUBSTRING
Use the tabs to select the file to bl The next instruction to be
be displayed in the Code View moy ¥3 Xexecuted is highlighted
hl pri
00001014 :EF000011 swi 0x11
SearchString:
00001018 :E92D403E stmfd  r13!,{rl-r5,rid}
I

:E3E00000

he address of an instruction
displayed in hexadecimal form)

00001024 :E5D14000 TaTh T3, [T1]
00001028 :E 3540000 cmp rd ,H0x00
0000102 0

e e R - -
The binary representation of an instruction

00001030

00001034 (displayed in hexadecimal form)

00001038 :E1A01002 oY TI;T=

0000103C:EBOD00DSE hl Start=sWHith

00001040 :E1A05000 moy r5,.r0

00001044 :ESBDODOF ldmfd r13!  {rD-r3} il

Figure 2. Code View

When a file is opened and successfully assembled and linked, its contents are displayed in the Code
View, as described above, and the first instruction to be executed is highlighted. When multiple files are
opened (see section 5.4), the file in which execution must start is displayed in the Code View with the
first instruction highlighted. The other files can be viewed by clicking on the tabs at the top of the Code
View.
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4.6 Registers View

The Registers View displays the contents of the 16 general-purpose user registers available in the ARM
processor, as well as the status of the Current Program Status Register (CPSR) and the condition code
flags (the leftmost 4 bits of the CPSR, as displayed below the condition code flags in the simulator).
Additionally, the Vector Floating Point (VFP) registers are available for display in the tab labelled “Float-
ing Point”. These registers represent the 32 Single Precision registers or the 16 Double Precision Regis-
ters of the VFP. Note that these two sets of registers are overlapped.

The General Purpose Registers are selected by clicking on the “General Purpose Registers” tab in the
Registers View. The contents of the general purpose registers can be displayed in hexadecimal, signed
decimal, or unsigned decimal formats. Use the Hexadecimal, Signed Decimal, and Unsigned Decimal
buttons at the top of the Registers View to switch between display formats (see Figure 3).

When an instruction is executed using one of the step commands (see section 5.1) or when a sequence of
instructions is executed using the Debug > Run option or the Continue button (see section 4.3), any reg-
isters and condition code flags that were written to during the execution of the instruction(s) are high-
lighted after the execution of the instruction(s) has finished.

G | P | .
SAESAIE IF?aU”g G| Use these buttons to switch Registers R10-R15 are also labelled:
Hexadecimal .
Oreioned Deama between the Hexadecimal,
Unsigned Decimal and Table 3.
Signed Decimal Si 1 Deci I displ
~=— - —= igned Decimal display —
RO ELEESEFL d R10 (sl stack limit
R1 -00001240 moaes
R2 100001246 .
RS 00000000 R11 |fp frame pointer
o — Registers that were . .
R5 100000000 s . R12 |ip intra-procedure-call scratch
- e written to during the .
: . register
R7 100000000 execution of the last
RS :00000000 instruction (or i
R B omtegagutntetel S R13 |sp stack pointer
R10 (s1) : 00000000 equenc f ¢ ) )
T (fp) 00005310 tions) R14 |Ir link register
R12 (ip) : 00000000
3 (=p) - 00005348 R15 |pc program counter
R14 (1x) : 00000000
5 {pc) :0000101c
CPSR Register
ﬂegative (H) :0
Zero (Z) 0
Carry (C) L Condition
Overflow (V) :0
IR Disable:1 Code Flags
FIQ Disable:1l
CPU HMMode :System
_____________ CPSR (Current Program
(EEOEEE " Status Register)
Figure 3. General Purpose Registers View.

The Floating Point Registers are selected by clicking on the “Floating Point” tab in the Registers View.
The Floating Point Registers can be viewed as Single Precision or Double Precision registers. Use the Sin-
gle Precision or Double Precision tabs at the top of the Registers View to switch between the display
types (see Figure 4).
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5. Debugging a Program

ARMSim# provides a number of features that enable users to debug ARM assembly programs, includ-
ing execution controls to step through and restart programs, Reload and Open Multiple commands,
and breakpoints. Sections 5.1 and 5.2 describe the execution controls. Sections 5.3 and 5.4 describe the
Reload and Open Multiple commands, respectively, and section 5.5 explains how to manage break-
points.

5.1 Stepping Through a Program

To step through a program one instruction at a time, use either the Step Into button or the Step Over
button on the toolbar, or alternatively, select Debug > Step Into or Debug > Step Over.

After an instruction has been executed using either Step Into or Step Over, both the next instruction to
be executed and any memory locations in the Registers, Memory, and Cache Views that were written to
during the execution of the instruction are highlighted.

For most instructions, the results of both Step Into and Step Over are identical; however, when an
instruction is a branch to a subroutine, Step Into executes the branch and moves to the first instruction
of the subroutine. In contrast, the Step Over executes the whole subroutine and moves to the instruction
after the branch in the original subroutine. Therefore, if a program consists of multiple files and there is
a branch from a subroutine in one file to a subroutine in another file, executing the branch using Step
Into also changes the file displayed in the Code View.

5.2 Restarting a Program

To restart a program, click the Restart button on the toolbar, or select Debug > Restart. Restarting a pro-
gram resets the registers, cache, and memory; it sets the program counter to the address of the first
instruction in the program; and it highlights this instruction (the next instruction to be executed).

5.3 Reloading a Program

To reload a program, click the Reload button on the toolbar, or select File > Reload. Reloading a pro-
gram loads a new copy of the file from the hard drive; it resets the registers, cache, memory, stack, and
watches; it sets the program counter to the address of the first instruction in the program; and it high-
lights this instruction (the next instruction to be executed).

5.4 Opening Multiple Files

To open multiple files, select File > Open Multiple. Then, click the Add button in the MultiFileOpen
dialog box; navigate to the folder, in which the files are stored; and double-click the file to be opened.
Repeat the three steps in the previous sentence until all of the files to be opened have been added to the
list in the dialog box. Then, click OK to open the files. When the files have been successfully opened, the
contents of the file that contains the _start (or main) subroutine will appear in the Code View with the
first instruction in this subroutine highlighted.

To remove a file from the list of files to be opened, select the filename in the dialog box, and click the
Remove button. To remove all of the files from the list of files to be opened, click the Clear button.

Notes:
¢ The files to be opened must be ARM assembler source (.s) files, ARM object (.0) files, or a combi-
nation of source and object files.
¢ If a file does not appear in the directory listing in the dialog box, one must check that the appro-
priate file type has been selected.
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General Purpose  Floating Point

Single Use these buttons to switch
between the Single or Double
DoLble

precision Floating Point

do .14159 Registers
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d2 Registers that were written
d3 .71828 ] to during the execution of the
d4 .43656 |l last instruction (or sequence
a5 of instructions)
(a6 :7.38901

0.0835

0.
~l1
00000000 o] oo W

FCPSR Register |

Hegative (N) : 0
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Carry (C) ] @ Condition Code Flags
Overflow (V) : 0

Stride :0

Length 0 |

e FPCPSR (Floating Point
0x00000000 IH Current Progmm%tatus

Figure 4. Floating Point Registers View.

¢ If the contents of the file appear in the Code View, but the first instruction is not highlighted,
check the Output View for compiler errors (see section 6.3).
*  When the file is opened, it is automatically assembled (if it is a source file) and linked.

5.5 Breakpoints

A breakpoint is a user-defined stopping point in a program (i.e. a point other than an SWI 0x11 instruc-
tion, at which execution of a program should terminate). When a program is being debugged, break-
points are used to halt execution of the program at predefined points so that the contents of storage
locations, such as registers and main memory, can be examined to ensure that the program is working
correctly.

When a breakpoint is set and the program is run using either the Debug > Run option or the Continue
button (see section 4.3), execution of the program stops just before execution of the instruction at which
the breakpoint is set (see Figure 5).

10
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To set a breakpoint, double-click the line of code, at which the breakpoint should be set. Alternatively,
step through the code to the line, at which the breakpoint should be set, and then select Debug > Toggle
Breakpoint. When the breakpoint is set, a large red dot appears in the Code View next to the address of
the instruction at which the breakpoint was set.

To clear a breakpoint, double-click the line of code, at which the breakpoint is set. Alternatively, step
through the code to the line, at which the breakpoint is set, and then select Debug > Toggle Breakpoint.
To clear all of the breakpoints in a program, select Debug > Clear All Breakpoints.

Note:
¢ Clear All Breakpoints clears the breakpoints in all files that are currently open.

ReverzeCopy.s

00001020:E59F3028

When the program is run, execution stops
just before execution of the instruction
where the breakpoint is set

Figure 5. Breakpoints.

6. Additional Views

In addition to the Code and Register Views discussed in sections 4.5 and 4.6, respectively, ARMSim#
includes Watch, Memory, Output, Stack, and Cache Views that enable users to observe the data trans-
fers within the system, as well as the output of the system. The following sections describe these addi-
tional views and explain any commands and settings associated with them.

6.1 Watch View

The Watch View displays the values of variables that the user has added to the watch list, which is a list
of variables that the user wishes to monitor during the execution of a program.

To add a variable to the watch list, select Watch > Add Watch. Alternatively, right-click in the Watch
View, and select Add Watch from the context menu. In the Add Watch dialog box (see Figure 6), select
the file, in which the variable appears; the label that is attached to the variable; and the display type of

11
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the variable. If applicable, specify the integer format of the variable, and select the base, in which the
integer representation of the variable should be displayed. Click OK.

To remove a variable from the watch list, select the variable in the Watch View, and then select Watch >
Remove Watch. To remove all of the variables from the watch list, select Watch > Clear All. Alterna-
tively, right-click in the Watch View, and select Clear All from the context menu.

Notes:
¢ Although Remove Watch appears in the Watch menu, this option has not yet been implemented.
¢ The Watch View does not display arrays; however, it is possible to display the first item of an
array by treating it as a scalar variable and adding it to the watch list, as described above.

AddWatch E@@

Filez Labels
SubSkingSearchs. z digitz Dizplay Az Integer Format
douote .
EEI;IL;FSTHEQMSQ " Byte * Signed
%p:;?fENMig ~ Halword " Unzigred
w c e
4 " Character * Decimal
" Shing " Hexadecimal
Ok Cancel |
A
Wakchiigw
Lab¥ Yalue
tens 1000000000

Figure 6. Adding a Watch.

6.2 Memory View

A Memory View displays the contents of main memory. In this view, each row contains an address fol-
lowed by a series of words from memory (see Figure 7).

Since the entire main memory cannot be displayed in a single Memory View, each Memory View shows
only a part of memory. The address in the top left corner of the view specifies the word, at which the part

12



ARMSim User Guide

of memory displayed in the view begins, and the size of the view determines the number of words dis-
played.

To display a different part of memory, enter a hexadecimal address from 0 to FFFFFFFF into the text box
in the top left corner of the Memory View. Alternatively, use the up and down arrows beside the text
box to select lower and higher memory addresses, respectively. The contents of memory can be dis-
played as 8-bit bytes, 16-bit halfwords, or 32-bit words. Use the three buttons in the Word Size box in the
top right corner of the Memory View to switch among the three display formats.

ﬂ ]“ [The address of the first word where the Word Size
1000

display of memory in this view begins
pray f 4 8 [ aBit 166k SEBit]

Qoooio0o  ESSFO003C ESS00000 ES9F1035 ES911000 ES9F4034  E2405001 A06004  E0224695
Qooo10z0  ES9F3023 E=300001 4.':'.I:IEIEIEIEI4 EZ511001 4.':'.I:IEII:II:II:IE 4124004 F E4534004  EAFFFFFS
00001040 EFD00011 00001054 Use these buttons to switch
00001060 00000002 00000003 between the 8-bit, 16-bit
00001080 E3A03000 ESDL4000 and 32-bit display modes
noooloa0  EADOOOOZ  EZ511001 EXMG3001 EAFFFFF4  ESBLSOLE
nonolocn  ESSsa0n0  osnooons  E4d400]  Ei1Ssonod 18000001 EAFFFFFS  ESS00000 ESBCSO1E
Memory locations that were written to during the executios} 0001 E340002E EAQDDOOD  E3A0002D0

of the last instruction (or sequence of instructions) 0001 BADODOLT 14000000 E3A0G001
0o04 44000006  EAD0000Z  EOSOO0004

Qoooi1140  E3S00000 CAD0000:2 E1AD1000 EZ355001 EAFFFFF3  E3S50000 14000001 E3560001
EIEIEIEIIIEEI 1AFFFFES  E3A06001 ESQFEIEI":EI E?IIIEIEIIIIS E4Z20001 EAFFFFE4  ESCFOO040  ESC20000

oo 1EEI O0SE06E0  DOOF4240 nnmasm aonoz710M00000SEs 0000064 HOODODDA unnnunm
Address | 00000000 00000000 00000000 [Memory Values | GCES006F 54530060 474E4952
OA736920  DADDZZO0  Z0R46E61 DAOO0AH7 20736177  GE7SEFAG
00001240 74612064 736F7020 6FAO7469 0AOZOEE 20736177 Z0746F6E  GETSEFGA6  OO0000G4
00001260 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000

Figure 7. Memory View.

When an instruction is executed using one of the step commands (see section 5.1) or when a sequence of
instructions is executed using the Debug > Run option or the Continue button (see section 4.3), any
memory locations that were written to during the execution of the instruction(s) are highlighted after the
execution of the instruction(s) has finished.

The properties of main memory, including its starting address, the stack area, and the heap area, can be
customized to suit the user’s preferences. To change these properties, select File > Preferences, and click
the Main Memory tab. Type in new values for the starting address, stack area, and heap area, or use the
arrow buttons beside each property to adjust the value of that property (see Figure 8). Click OK, and
then reload the program (see section 5.3) to refresh the Memory View(s).

Notes:
¢ If a store (STR) instruction is executed, but the value in memory does not change, check the
Cache Preferences to make sure that the Write Policy is not set to Write Back. If it is, set it to
Write Through. (See section 6.5 for information on setting the Cache Preferences.)
¢ The simulator can have multiple Memory Views, each of which displays a different region of
memory. To open additional Memory Views, select View > Memory.

13



ARMSim¢# User Guide

¢ When the display size is set to 8-bit, the ASCII representation of each row of bytes is displayed at
the end of the row.

¢ When the display size is 16-bit or 32-bit, the assignment of byte addresses is little-endian.

¢ Inthe Memory View, all cells that are part of the memory region allocated to the program are
shown in hexadecimal notation (e.g. ELA03000, 00000000); cells outside the allocated memory
region are shown as question marks (e.g. ??7???2??).

28 PreferencesForm il x
Ganaral Main Memory | Cache |

Starting Address of Main Memory 1000 .

Stack Area(KB) 32 3
Heap Area(KB) 32 =

Memory Fill Pattern 81218181

I Stop program on misabgned memony accessT

Figure 8. Main Memory Preferences Form.

6.3 Output View

The Output View contains a row of two tabs labelled “Console” and “Stdin/Stdout/Stderr”. Selecting the
tab labelled “Console” brings a window to the front where the simulator outputs success and error mes-
sages. After the simulator has loaded the program, any assembler or linker errors are displayed here (see
Figure 9 for an example). To find the source of an error message displayed in the Output View (see Fig-
ure 9), double-click the message, and scroll up one line in the Code View. Additional information will be
displayed here such as instruction counts and runtimes.

Selecting the tab labelled “Stdin/Stdout/Stderr” brings a window to the front where output from the
user program is displayed as a result of using software interrupts (SWI instructions) to perform I/O.
Output directed to either the standard output or standard error (Stdin/Stdout) are displayed in this
tabbed window. Any request to read from the standard input device (Stdin) causes the program to
freeze until the input is provided on the keyboard; that input is echoed in this tabbed window as well.

14
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To copy text from the one of the Output View tabbed windows, right-click in the view, and select Copy
to Clipboard from the context menu. To clear the contents of the Output View tabbed window, right-
click in the tab, and select Clear from the context menu.

6.4 Stack View

The Stack View displays the contents of the system stack. In this view, the memory address of a value
and its binary representation are displayed on a single line, separated by a colon and displayed in hexa-
decimal format. Furthermore, the top word in the stack is highlighted (see Figure 10). Note that the sys-
tem stack is a full descending stack.

| Dutputview 2 x|
console | stan/staout/stden |

Loading assembly language file C:\ARMSim.150\testFiles\experiment.s

The following assembler/loader errors occurred ...

[File:C:\ARMSim.150\testFiles\experiment.s Line:& Column:10 Message:Undefined symbal Al]
End of assembler errors

B ouiputview [ 1atcriview B Memoryviews

Figure 9. Error Message.
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Stackifiew

00005380 :
00005364 :
00005h3E8:
000053BC:
000053C0:
000053C4:
000053CH:
00005h3CC:
00005300 :
00005304 :
00005308 :
000053DC :
000053ED:
000053E4:
000053E8:
000053EC:
000053F0:

00000000
Q0000000
00000000
00000000
00001240
000012446
00000000
00000048
000053F0
000010AC
00001240
000012446
00001240
000012446
00000000
00000000
00000000
00001010

1 . Top of the Stack

L |Stack

000053F4:

| Value

00005404:

00005408 : 00000000
0000540C : 00000000_| ———~[Memory Address

Figure 10. Stack View.

6.5 Cache Views

The Cache Views display the contents of the L1 cache. The cache can have different organizations. The
one used by ARMSim# can be selected by the user before an ARM program is executed. The cache can

consist of either a unified data and instruction cache, displayed in the Unified Cache View, or separate
data and instruction caches, displayed in the Data and Instruction Cache Views, respectively, depend-
ing on the cache properties selected by the user.

To set the cache properties, select File > Preferences, and click the Cache tab. Then, use either the Cache
Preferences Form (see Figure 11) or the Cache Wizard to change the current cache settings, and click
OK. To restore the default cache properties, select the Restore Defaults button on the Cache Preferences
Form.

When using the Cache Preferences Form to set the cache properties, begin by selecting the type of cache.
Table 3 lists the available cache configurations. Then, set the size of the cache(s). Once the Cache Size has
been set, selecting a value for either the Block Size or the Number of Blocks causes the remaining set-
tings in the Cache Size box to assume the appropriate values, so that the three properties satisfy the fol-
lowing equation:

Cache Size (bytes) = Block Size (bytes) x Number of Blocks
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Next, select the Associativity of the cache(s). If Set Associative is selected, set the Blocks per Set, and
select a Replacement Strategy. Finally, select the Write and Allocate Policies for the Cache or Data
Cache.

Table 3. Cache Configurations.

Configuration Settings

Unified Data and Instruction Cache Enable the Unified Data and Instruction Cache.

Separate Data and Instruction Caches |Disable the Unified Data and Instruction Cache, and enable
the Data Cache and the Instruction Cache.

Data Cache Only Disable the Unified Data and Instruction Cache and the
Instruction Cache, and enable the Data Cache.

Instruction Cache Only Disable the Unified Data and Instruction Cache and the
Data Cache, and enable the Instruction Cache.

No Cache Disable the Unified Data and Instruction Cache, the Data
Cache, and the Instruction Cache.

B Preferenceshonm A
Gerrel | Main Mamony Cache

F  Unified Dala and Instruction Cache?

F

64 Js g el e e

Cache
M Enabiled
Cache Size AzEoCinhity Beplacement Stralagy
Cache Sire{Bwies)  Block SizeiByies) Number of Blocks T Fully Azsocinthve[1 Set)  Blocks Par Sel | Bandom
PEeL Shis e e T
= - = L - = Bound Robin
 Direct Mapped
‘White Palicy Allecate Policy
& ‘Writa Through £ Pasliocely
VWit Back 1 Write Allocate
= Bodh
Rastore Dafaulls | CacheWizerd |
Cancel [6],4 I

Figure 11. Cache Preferences Form.
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In the Cache Views, the boundaries of sets are marked by the blue square brackets along the left-hand
side of the view (see Figure 12). Each row consists of a memory address, followed by a cache block that
shows the contents of the block at this address in memory.

When an instruction is executed using one of the step commands (see section 5.1) or when a sequence of
instructions is executed using the Debug > Run option or the Continue button (see section 4.3), any
cache blocks that were written to during the execution of the instruction(s) are highlighted after the exe-
cution of the instruction(s) has finished.

When the Write Policy is set to Write Back, a dirty block is marked by a red dot to the left of the row.

To clear all of the cache blocks, select Cache > Reset. Resetting the cache purges all of the dirty blocks,
invalidates all of the cache blocks, and sets all of the cache statistics to zero. To purge all of the dirty
blocks in the cache, select Cache > Purge. This command has no effect unless the Write Policy is set to
Write Back.

To view the cache statistics, including the hit and miss rates, select Cache > Statistics. To clear all the
cache statistics, click the Reset button on the Cache Statistics display.

Note:
e The Instruction Cache is sometimes referred to as the Code Cache.

UnifiedCacheiisw o o

| Cache Set

0o001000:  e59F003c 5900000 e59F1035 5911000
IR TITTRIIT OPTYTIVIY  OTRIVIYRT TYRIYIYY

TR Py Py Py Py

[EIEIEIEIIEIIEI: £59f4034  e2405001 e3al5004  =0224695

£2500001  4a000004 2511001 Jtp— |Cache Block

T Py Py

{=cafanza

1
00001030:  4a000002 e4124004 4534004  eafFFFFS Memory Address

TR Py Py Py Py

| Cache block that was written td
during the execution of the last

fEIEIEIEIlEI"rEI: ef000011 00001054 00001053 EIEIEIEIIEISE-]-‘—

ST FEEERRT O YERYETYY RRYRRYYY YRR , )

- instruction (or sequence of
Q0o01050; 00001063 00000003 00000003 00000001 instructions)
TR Py Py Py Py

d'-nnnmnan: 0000D0DZ 00000003 00000003 00000000 Jeeg—y Dirty Block

L PRI PR PR PR PR
.
PRI PR PR PR PR
YT TIFITITT TRIIVIIY OTTIVIIYT TYIIIYIY

Figure 12. Cache View.

7. Some ARMSim# Limitations

The ARMSim# is an aid for learning the operation of the ARM architecture. It does not implement every
feature that can be found on the ARM. Some of the more important limitations are listed below.
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* The ARM architecture supports both little-endian and big-endian access to memory. The ARM-
Sim# supports only the little-endian format (the same as the Intel architecture which hosts the
ARMSim#).

¢ The ARM architecture has a special mode of execution called “Thumb mode” which is intended
for embedded system applications where memory is a scarce resource. Each thumb instruction
occupies only 2 bytes. Thumb mode is not currently supported by ARMSim#.

8. SWI Codes for I/O in ARMSim#: the first Plug-in

Plug-ins have been used to extend the functionality of ARMSim# in a modular fashion. A full descrip-
tion of the Plug-in designs is beyond the scope of this document. The default installation of ARMSim#
comes with two Plug-ins module extensions: SWllnstructions and EmbestBoard. The SWilnstructions
plug-in implements SWI codes to extend the functionality of ARMSim# for common I/O operations and
its use is detailed in this section. Important Note: All Plug-ins have to be enabled explicitly by checking their
option in the File > Preferences menu and selecting the appropriate line from within the tab labelled Plugins.

8.1 Basic SWI Operations for I/O

The SWI codes numbered in the range 0 to 255 inclusive are reserved for basic instructions that ARM-
Sim# needs for I/O and should not be altered. Their list is shown in Table 4 and examples of their use fol-
low. The use of “EQU” is strongly advised to substitute the actual numerical code values. The right hand

column shows the EQU patterns used thoughout this document in the examples.

Table 4. SWI I/O operations (0x00 - 0xFF)

Opcode |Description and Action Inputs Outputs EQU
swi 0x00 |Display Character on  |r0: the character SWI_PrChr
Stdout
swi 0x02 |Display String on r0: address of a null ter- |(see also 0x69
Stdout minated ASCII string below)
swi Ox11 |Halt Execution SWI_Exit
swi 0x12 |Allocate Block of Mem- |r0: block size in bytes rO:address of block [SWI_MeAl loc
ory on Heap
swi 0x13 |Deallocate All Heap SWiI_DAlloc
Blocks
swi 0x66 |Open File r0: file name, i.e. address of |r0O:file handle SWI1_Open
(mode values in r1 are: 0 |a null terminated ASCII If the file does not
for input, 1 for output, 2 |string containing the name |open, a result of -1
for appending) rl: mode is returned
swi 0x68 |Close File r0: file handle SWi_Close
swi 0x69 |Write String to a File or |10: file handleor Stdout SWI_PrStr
to Stdout rl: address of a null termi-
nated ASCII string
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Table 4. SWI I/O operations (0x00 - 0xFF)

Opcode |Description and Action Inputs Outputs EQU

swi Ox6a |Read String from a File |r0: file handle r0: number of SWI1_RdStr
rl: destination address bytes stored
r2: max bytes to store

swi Ox6b |Write Integer to a File  |10: file handle SWI_Print
rl: integer

swi Ox6¢ |Read Integer from a File |r0: file handle r0: the integer SWI_RdInt

swi 0x6d |Get the current time r0: the number of |SWI1_Timer

(ticks) ticks (milliseconds)

8.1.1 Detailed Descriptions and Examples for SWI Codes for I/O

¢ Display Character on Stdout: swi 0x00

A character is a 1-byte entity. The SWI O0XO0O0 instruction from the SWI table of the simulator (normally
used with .equ SWI_PrChr,0x00) can print such a character to the stdout view when assigned to
register r0.

The lines of code below print the character labelled “A” to the Stdout, followed by the new line character.
Note that the assignment of a character to a register needs the single left quote in the syntax for the
immediate operand.

mov rO,#’A
. . . swi PrChr
Displays one character in the output window. mov ro.#>\n
swi PrChr
¢ Display String on Stdout: swi 0x02
Idr rO,=MyString
Displays a string in the output window. See also swi 0x02
the more general SWI  OX69 below. A
MyString: .asciz "Hello There\n"
¢ Halt Execution: swi 0x11
Stops the program. Swi SWI_EXxit
¢ Allocate Block of Memory on Heap: swi 0x12
mov r0,#28 (@get 28 bytes
Obtain a new block of memory from the heap swi SWI_MeAlloc
area of the program space. If no more memory is Idr rl,=Address
available, the special result -1 is returned and the str rO, [ri]
C bit is set in the CPSR. .-
Address: -word O
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¢ Deallocate All Heap Blocks: swi 0x13

Causes all previously allocated blocks of memory swi DAlloc
in the heap area to be considered as deallocated

(thus allowing the memory to be reused by future

requests for memory blocks).

¢ Open File: swi 0x66

Opening a file for input. Assume the following in the data section:

InFileName: _asciz "Infilel.txt"”

InFileError: .asciz "Unable to open input file\n"
.align

InFileHandle: .word 0

The following lines of code open the file called “Infilel.txt” for input and store its file “handle”,
returned in RO by the opening call, into the appropriate memory location:.

Idr rO,=InFileName @ set Name for input file
mov rl1,#0 @ mode is input

swi SWI_Open @ open file for iInput

bcs InFileError @ if error?

Idr rl1,=InFileHandle @ load input file handle
str rO,[r1] @ save the file handle

Thus to open a file for input, one needs to load the address of the string containing the file name into RO,
set the input mode = 0 into R1, and execute the SWI instruction with “0x66” as operand. By testing the
carry bit upon return using the BCS instruction, one makes sure that the file has been opened properly,
otherwise a message should be printed and the program should exit.

Opening a file for output. Assume the following in the data section:

OutFileName: .asciz "Outfilel.txt"

OutFileError: .asciz "Unable to open output file\n"
.align

OutFileHandle: .word 0

The following lines of code open the file called “Outfilel.txt” for output and store its file “han-
dle”, returned in RO by the opening call, into the appropriate memory location:.

Idr rO,=0utFileName @ set Name for output File
mov rl,#1 @ mode is output

swi SWI_Open @ open file for output

bcs OutFileError @ if error ?

Idr rl1,=OutFileHandle @ load output file handle

str rO,[r1] @ save the file handle

Thus to open a file for output, one needs to load the address of the string containing the file name into
RO, set the output mode =1 into R1, and execute the SWI instruction with “0x66” as operand. By testing
the carry bit upon return using the BCS instruction, one makes sure that the file has been opened prop-
erly, or else a message should be printed and the program should exit.
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Summary of the swi 0x66 file opening instruction.

Idr ro,=InFileName
mov ril,#0 @ input mode
swi SWI_Open
Opens a text file for input or output. The file bcs NoFileFound
name is passed via 10. Register r1 specifies the file Idr ri,=InFileHandle
access mode. If r1=0, an existing text file is to be str rO, [r1]
opened for input. If r1=1, a file is opened for out- .
put (if that file exists already, it will be overwrit- Idr rO,=0utFileName
ten, otherwise a new file is created). If r1=2, an mov rl,#1 @ output mode
existing text file is opened in append mode, so swi SWI_Open
that any new text written to the file will be added bcs NoFileFound
at the end. Idr ri,=OutFileHandle
If the file is opened successfully, a positive num- str ro,[ri]
ber (the file handle) is returned in r0. Otherwise, S
a result of -1 is returned and the C bit is set. OutFileHandle: .word O

InFileHandle: .word O
InFileName: .asciz "Infilel.txt"
OutFileName: .asciz "Outfilel.txt"

Note: The default location for the file is the same folder as the assembler source code file. If another loca-
tion is desired, a full path to the file location can be used. For example, the code shown below opens (or
creates) a text file in the Windows Temporary directory.

IdrrO,PathName
movrl,#1 @ output mode
swiSWI_Open

PathName:
.asciz "C:\\TEMP\\MyFile.txt"
¢ Close File: swi 0x68

At the end of execution a file should be properly closed, or else it may be inaccessible to other applica-
tions. The following lines of code show how to close both the input and output files used as examples
above.

@ load the file handle

Idr ro,=InFileHandle

Closes a previously opened file. Unless a file is Id': ro, [ro]

. . . swi SWI_Close
closed, it often cannot be inspected or edited by .
nother program (e.g. TextPad) @ load the file handle

another programie.g. lexthad). Idr ro,=OutFileHandle
Idr ro, [rO]
swi SW1_Close

¢ Write String to a File: swi 0x69

Assume you have the following in your data section:

MatMsg: .asciz "\nThis is the resulting matrix:\n"
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Also assume that an output file has been opened as shown above and that its name is stored in “Out-
FileName” and its file handle is stored in “OutFileHandle”.

Then the following lines of code print the string “\nThis s the resulting matrix:\n”to
the output file opened as shown above. The string is preceded and followed by a new line since the char-
acter “\n” is embedded at the end of the string.

IdrrO0,=0OutFileHandle@ load the output file handle

Idrr0, [rO] @ RO = File handle
Idrrl,=MatMsg @ R1 = address of string
swiSWI_PrStr @ output string to file
Writes the supplied string to the current position Idr rO,=OutFileHandle
in the open output file. The file handle, passed in Idr rO,[rO]
r0, must have been obtained by an earlier call to Idr ril1,=TextString
the Open File SWI operation. swi 0x69

bcs WriteError

TextString: .asciz "Answer =

Note: The special file handle value of 1 can be mov rO,#1

used to write a string to the Stdout output win- Idr rl1,=Message

dow of ARMSim# (giving the same behaviour as swi 0x69 @ display message
swi 0x02). A brief example appears on the .-

right. Message: .asciz "Hello There\n"

¢ Read String from a File: swi Ox6a

Reads a string from a file. The input file is identi- Idr rO,=InFileHandle
fied by a file handle passed in RO. R1 is the Idr rO,[rO]

address of an area into which the string is to be Idr ri1,=CharArray
copied. R2 is the maximum number of bytes to mov r2,#80

store into memory. One line of text is read from swi Ox6a

the file and copied into memory and a null byte bcs ReadError
terminator is stored at the end. The line is trun- .---

cated if it is too long to store in memory. The InFileHandle: .word O
result returned in 10 is the number of bytes CharArray: .skip 80

(including the null terminator) stored in memory.

¢ Write Integer to a File: swi 0x6b

Converts the signed integer value passed in rl to Idr rO,=OutFileHandle
a string and writes that string to the file identified idr rO,[rO]

by the file handle passed in r0. Assumes that an mov rl,#42

output file has been opened and that its name is swi SWI_Print

stored in “OutFi leName” and its file handle is
stored in “OutFileHandle”. The lines of code
on the right print the integer 42 contained in reg-
ister R1 to the opened output file.
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Note: The special file handle value of 1 can be mov rO,#1
used to write the integer to the Stdout output mov rl1,#99
window. An example appears on the right. swi Ox6b ; display 99

¢ Read Integer from a File: swi 0x6c

Reads a signed integer from a file. The file is Idr rO,=InputFileHandle
identified by the file handle passed in r0. The Idr rO,[rO]

result is returned in r0. swi 0x6¢c

If a properly formatted number is not found in bcs ReadError

the input, the C bit is set and r0 is unchanged. By @ the integer is now in rO
testing the carry bit upon return using the BCS .

instruction, one makes sure that the integer has

been read properly.

9. SWI Operations for Other Plug-Ins: the Embest Board Plug-In

The SWI codes numbered greater than 255 have special purposes. They are mainly used for interaction

with Plug-in modules which can be loaded with the ARMSim# simulator. Table 5 provides a current list
of these codes as they are used in the Embest Board Plug-in View. Examples of their use follow with illus-
trations of the corresponding component. The use of “EQU” is strongly advised to substitute the actual
numerical code values. Examples of code is also provided at the end of the section.

A diagram representing schematically the features of the Embest board is shown in Figure 13.

/A 8-segment "\ /~ Two LED lights wo buttons for input T 7
display for output 0 1 2 3

for output
‘ ‘ 4 5 6 7

8 9 10 |||f 11

12 ([ 13 (I 24 (||| 15
@ Keyboard for input/

N —

Figure 13: A diagrammatic view of the available controls and displays on the
Embest Board View

There are 5 main components in this view available for programming;:

1. One 8-segment display (output).
2. Two red LED lights (output).
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Two black buttons (input).
Sixteen blue buttons arranged in a keyboard 4 x 4 grid (input).
One LCD display screen, which is a grid of 40 columns by 15 rows of individual cells. The coordi-

ARMSim User Guide

nates for each LCD cell are specified by a {column, row} pair. The top-left cell has coordinates {0,0},
while the bottom-right cell has coordinates {39,14}. Each cell can contain exactly one ASCII charac-

ter.

Table 5. SWI operations greater than 0xFF as currently used for the Embest board Plug-In

Opcode Description and Action Inputs Outputs
swi 0x200 |Light up the 8-Segment r0: the 8-segment Pattern |The appropriate segments light
Display. (see below in Figure 14 for |up to display a number or a
details) character
swi 0x201 |Light up the two LEDs. 10: the LED Pattern, Either the left LED is on, or the
where: right, or both
Left LED on = 0x02
Right LED on = 0x01
Both LEDs on = 0X03
(i.e. the bits in position 0
and 1 of r0 must each be
set to 1 appropriately)
swi 0x202 |Check if one of the Black |[None r0 = the Black Button Pattern,
Buttons has been pressed. where:
Left black button pressed
returns r0 = 0x02 ;
Right black button pressed
returns r0 = 0x01;
(i.e. the bits in position 0 and 1
of r0 get assigned the appropri-
ate values).
swi 0x203 |[Check if one of the Blue  |None (see below in Fig-  |r0 = the Blue Button Pattern (see
Buttons has been pressed. |ure for details) below in Figure ).
swi 0x204 |Display a string on the r0: x position coordinate |The string is displayed starting
LCD screen on the LCD screen (0-39); |at the given position of the LCD

rl: y position coordinate
on the LCD screen (0-14);
r2: Address of a null ter-
minated ASCII string.
Note: (x,y) =(0,0) is the top
left and (0,14) is the bot-
tom left. The display is
limited to 40 characters
per line.

screen.
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Table 5. SWI operations greater than 0xFF as currently used for the Embest board Plug-In

Opcode

Description and Action

Inputs

Outputs

swi 0x205

Display an integer on the
LCD screen

r0: x position coordinate
on the LCD screen (0-39);
rl: y position coordinate
on the LCD screen (0-14);
r2: integer to print.

Note: (x,y) =(0,0) is the top
left and (0,14) is the bot-
tom left. The display is
limited to 40 characters
per line

The string is displayed starting
at the given position of the LCD
screen.

swi 0x206

Clear the display on the
LCD screen

None

Blank LCD screen.

swi 0x207

Display a character on the
LCD screen

r0: x position coordinate
on the LCD screen (0-39);
rl: y position coordinate
on the LCD screen (0-14);
r2: the character.

Note: (x,y) =(0,0) is the top
left and (0,14) is the bot-
tom left. The display is
limited to 40 characters
per line

The string is displayed starting
at the given position of the LCD
screen.

swi 0x208

Clear one line in the dis-
play on the LCD screen

r0: line number (y coordi-
nate) on the LCD screen

Blank line on the LCD screen.

9.0.1 Detailed Descriptions and Examples for SWI Codes for the Embest Board Plug-in

¢ Set the 8-Segment Display to light up: swi 0x200

The appropriate segments light up to display a number or a character. The pattern of segments to be lit
up is assigned to register RO before the call to SwWi 0x200. Figure 14 shows the arrangements of seg-
ments, and an example follows. Each segment is logically labelled and its byte code is shown in the list
in Table 6. For example, in Figure 14, to display the number “3”, segments “A”, “B”, “C”, “D” and “F”
must be illuminated. The code to be assigned to RO is computed by the logical OR of the individual byte

codes.
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Figure 14. The Pattern for the 8-Segment Display

r\C A >m Table 6: Segmen
t byte values
G B Display byte
values
A 0x80
G
B 0x40
C 0x20
E C
P 0x10
D 0x08
_/ )
b D7) [ |oxo4
F 0x02
G 0x01

Example: number “3” plus “dot”
_ G

~ [

As an example, the number 3 plus the
right hand dot would have a pattern
value computed as the logical OR of the
values of the segments “A,B,C,D,EP” to
form the integer: 0OX80 | 0x40 |
0x20 | Ox08 | 0x02 | Ox10 =
OXFA, tobe assigned to r0.

Below some segments of code are shown as examples for the 8-segment Display. The “ . equ” statements
are useful for accessing the byte values associated with the labels of each segment as shown in Figure 14.
An example of a possible declaration of data is also given in Figure 16 for the display of integers, where
the byte values representing a particular number are already “ORed” together within the array data

structure and can be indexed appropriately. It may be easier to use a data declaration for an array of

words and then index into it. Each element can be initialized to contain the value representing a number

by having the appropriate byte values “ORed” together.

Use “.equ” statements to set up the byte value
of each segment of the Display.

-equ SEG_A,0x80
.equ SEG_B,0x40
.equ SEG_C,0x20
-equ SEG_D,0x08
-equ SEG_E,0x04
-equ SEG_F,0x02
-equ SEG_G,0x01
.equ SEG_P,0x10

Figure 15: Possible data declaration for byte values for segments
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Digits:
-word SEG_A|SEG_B|SEG_C|SEG_D|SEG_E|SEG_G @0
A possible data dec- -word SEG_B|SEG_C @1
laration for an array -word SEG_A|SEG_B|SEG_F|SEG_E|SEG_D @2
of words which can -word SEG_A|SEG_B|SEG_F|SEG_C|SEG_D @3
be indexed to obtain -word SEG_G|SEG_F|SEG _B|SEG_C @4
the appropriate -word SEG_A|SEG_G|SEG_F]SEG_C]SEG_D @5
value for a number -word SEG_A|SEG _G|SEG_F|SEG_E|SEG_D]SEG _C @6
{0,...,9} to be dis- -word SEG_A|SEG_B|SEG_C @7
played. -word SEG_A|SEG_B|SEG_C|SEG_D|SEG_E|SEG_F]SEG_G @8
-word SEG_A|SEG_B|SEG_F|SEG_G|SEG_C @9
-word 0 @Blank display
Figure 16: Possible data declaration forinteger patterns

An example of a possible routine to display a number in the 8-segment Display using the declarations
given above is shown in Figure 17.

@ *** Display8Segment (Number:RO; Point:R1) ***
@ Displays the number 0-9 in RO on the
@ LED 8-segment display

Register RO and R1 are input @ If R1 = 1, the point is also shown

parameters, where RO contains [1]DISplta y_:? dSegmem:- 0-r2.1

the integer to be displayed and [2] ? dr: ig - :Ig :g;{s ATy

R1 contains “1” to display the [2] ldr 0 : [r2.r0, I1s1#2]

“P” segment, or “0” otherwise. ? > _ _
[4] tst ril,#0x01 @if ri=1,
[5] orrne rO,r0,#SEG_P @then show “P”’
[6] SWi 0x200

[7] 1dmfd sp!,{rO0-r2,pc}

Figure 17: A possible “Display8Segment” routine

In line [3], register IO is assigned the byte value corresponding to the indexed element of the array digits
from Figure 16. For example, to display the number “3”, after execution of line [2], the input register 'O
should contain the integer value 3 and register 2 contains the address of the array “DIgitS” . Then
the computation implied by “[r2, rO, Is1#2]” adds 12 bytes to the address currently in 12 (i.e. rO
shifted left by 2 positions, which evaluates to “3” x 4 = 12) and loads the word in position 3 of the array,
namely: .word SEG_A|SEG_B|SEG_F|SEG_C]SEG_D. In fact, this uses the segments
“A,B,C,D,F” to display the correct number. In line [4] the content of 'l is tested. If r1 =1 then the
segment “P” is added to the display, with its value ORed with the previous ones in 0.
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¢ Set the two LEDs to light up: swi 0x201

mov
swi
Light up the LEDs: the left or the right or both, mov
according to the value supplied by rO. swi
mov
swi
¢ Check if one of the Black Buttons has been pressed:
The call with swi 0X202 sets the content of rO swi
as:r0=2 if the left black button was pressed or cmp
rO=1, if the right black button was pressed. Test- beq
ing 10 enables follow up actions. bal

ARMSim User Guide

ro,#0x02
0x201 @ left LED on
ro,#0x01
0x201 @ right LED on
ro,#0x03
0x201 @ both LEDs on
swi 0x202
0x202
ro,#0x02
ActOnLeftBlack
ActOnRightBlack

¢ Check if one of the Blue Buttons has been pressed: swi 0x203

After the call with swi 0x203, test the content Swi 0x203
of r0O. The number in O corresponds to the posi- cmp ro,#1
tion of the blue button as depicted in Figure . For cmp ro,#2
example, if rO=2 then the blue button in posi- cmp ro,#3
tion 2 was pressed. - -
0 1 2 3
4 5 6 7
The keypad with 16 blue
8 9 10 || 11 <« — — - buttons as depicted in
the board view.
12 (iff 23 |f{f 14 |{f 15

KA Keyboard for input /

0x02, thatis,

in binary, where the bit in position “1” has been set.

They are arranged such that each button has a corresponding bit position in the 16-bit lower portion
of a word in register RO after the call to swi 0x203 to poll the keypad. The “number labels” placed in
the figure, which do not appear on the real keypad, also represent the corresponding bit position as
returned in RO. When a button is pressed, the corresponding bit is set.

For example, when the button in position “1” is pressed, the swi 0x203 instruction returns rO =

ro=00000000000000O0O0O0OO0OOOOOOCOOOOOOOOO11O

Figure 18. The Pattern for the Blue Buttons
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¢ Display a string on the LCD screen: swi 0x204

mov rO0,#4
Display the string whose address is supplied in mov rl,#1
2 on the LCD screen at position (x,y), where Idr r2,=Message
rO=x and rl=y. In this example, rO=4 and swi 0x204 @ display message

rl=y=1 (thatis, line 1 at column 4) .-
Message: .asciz '""Hello There\n"

¢ Display an integer on the LCD screen: swi 0x205

Display an integer on the LCD screen. The inte- mgx ::2 ’ ii
ger is in I2, to be shown at position (x,y), where mov r2.#23

rO=x and rl=y. In this example, r2=23, rO=4 and

rl=y=1 (thatis, line 1 at column 4 displays 23) Swi - 0x205 @ display integer

¢ Clear the display on the LCD screen: swi 0x206

Clear the whole LCD screen. swi L Y Glear sEreer

¢ Display a character on the LCD screen: swi 0x207

Display a character on the LCD screen. The char- mov rO0,#4

acter is in 2, to be shown at position (x,y), mov rl,#1

where here rO=x and rl=y. In this example, mov r2,#°Z

r2="Z, r0=4 and rl=y=1 (that is, line 1 at column swi 0x207 @display char
4 displays Z).

¢ Clear one line in the display on the LCD screen: swi 0x208

Clear only one line on the LCD screen, where the Idr ro,#5
line number is given in rO. Swi 0x208 @clear line 5

10. Code Examples

10.1 Example: Print Strings, Characters and Integers to Stdout using SWI Instructions for I/O
@@@ PRINT STRINGS, CHARACTERS, INTEGERS TO STDOUT
-equ SWI_PrChr,0x00 @ Write an ASCII char to Stdout
.equ SWI_PrStr, Ox69 @ Write a null-ending string
.equ SWI_Print,0x6b @ Write an Integer
.equ Stdout, 1 @ Set output mode to be Output View
.equSWI_Exit, Ox11 @ Stop execution
-global _start
-text
_start:
@ print a string to Stdout
mov RO, #Stdout @ mode i1s Stdout
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Idr R1, =Messagel @ load address of Messagel

swi SWI_PrStr @ display message to Stdout
@ print a new line as a string to Stdout

mov RO,#Stdout @ mode i1s Stdout

Idr r1, =EOL @ end of line

swi SWI_PrStr
@ print a character to the screen
mov RO, #"A @ RO = char to print
swi SWI_PrChr
@ print a blank character (from data)
Idr rO0,=Blank
1drbrO, [rO] @ RO = char to print
swi SWI_PrChr
@ print a second character to Stdout
mov RO, #"B @ RO = char to print
swi SWI_PrChr
@ print a new line as a character to Stdout
Idr roO,=NewL
Idrbr0, [rO] @ RO = char to print = new line
swi SWI_PrChr
@ print an integer to Stdout
mov RO,#Stdout @ mode i1s Output view
mov rl, #42 @ integer to print
swi SWI_Print
@ print a new line as a string to Stdout
mov RO,#Stdout @ mode i1s Output view
Idr rl1, =EOL @ end of line
swi SWI_PrStr
swiSWI_Exit @ stop executing: end of program

blank

.data
Messagel: .asciz'Hello World!"
EOL: .asciz "\n"'
NewL : .ascii "\n"'
Blank: .ascii e
.end

10.2 Example: Open and close files, read and print integers using SWI Instructions for I/O
@@@ OPEN INPUT FILE, READ INTEGER FROM FILE, PRINT 1T, CLOSE INPUT FILE

.equ SWI_Open, 0x66 @open a Tile
.equ SWI_Close,0x68 @close a file
.equ SWI_PrChr,0x00 @ Write an ASCII char to Stdout
.equ SWI_PrStr, 0x69 @ Write a null-ending string
-equ SWI_Print,0x6b @ Write an Integer
-equ SWI_RdInt,0x6c @ Read an Integer from a file
.equ Stdout, 1 @ Set output target to be Stdout
.equ SWI_Exit, Ox11 @ Stop execution
.global _start
-text

_start:

@ print an initial message to the screen
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mov RO,#Stdout @print an initial message

Idr R1, =Messagel @ load address of Messagel label

swi SWI_PrStr @ display message to Stdout
@ == Open an input file for reading oo ———————————=—
@ if problems, print message to Stdout and exit

Idr rO,=InFileName @ set Name for input file

mov rl,#0 @ mode is input

swi SWI_Open @ open file for input

bcs InFileError @ Check Carry-Bit (C): if= 1 then ERROR

@ Save the file handle in memory:

Idr rl,=InputFileHandle @ if OK, load input file handle

str rO,[r1] @ save the file handle
@ == Read integers until end of file ======================—=======
RLoop:

Idr rO,=InputFileHandle @ load 1nput file handle

Idr rO,[rO]

swi SWI_RdInt @ read the integer into RO

bcs EofReached @ Check Carry-Bit (C): if= 1 then EOF reached
@ print the integer to Stdout

mov rl,rO @ R1 = integer to print

mov RO,#Stdout @ target is Stdout

swi SWI_Print

mov RO,#Stdout @ print new line

Idr r1, =NL

swi SWI_PrStr

bal RLoop @ keep reading till end of file
@ == End of file ===============—===—=———————=——=——=—=—=—=—=—=—=—=======—==—=—=
EofReached:

mov RO, #Stdout @ print last message

Idr R1, =EndOfFileMsg
swi SWI_PrStr
@ == Close a file ===================——————=—=-==-=-=—=====—=———————=

Idr RO, =InFileHandle @ get address of file handle
Idr RO, [RO] @ get value at address
swi SWI_Close
Exit:
swiSWI_Exit @ stop executing

InFileError:
mov RO, #Stdout
Idr R1, =FileOpenlnpErrMsg
swi SWI_PrStr

bal EXxit @ give up, go to end
.data
.align
InFileHandle: -skip 4
InFileName: .asciz “whatever.txt"
FileOpenlnpErrMsg: .asciz "Failed to open input file \n"
EndOfFileMsg: .asciz "End of Ffile reached\n"
ColonSpace: .asciz": "
NL: .asciz "\n "' @ new line
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Messagel: .asciz

.end

ARMSim User Guide

"Hello World! \n"

10.3 Example: Useful patterns for using SWI Instructions for a Plug-In

This is a possible initial template to set the useful SWI codes for the Embest Board Plug-in

.equ SWI_SETSEGS, 0x200 @display on 8 Segment
.equ SWI_SETLED, 0x201 @LEDs on/off

-equ SWI_CheckBlack, 0x202 @check Black button

.equ SWI_CheckBlue, 0x203 @check press Blue button
-equ SWI_DRAW_STRING, 0x204 @display a string on LCD
-.equ SWI_DRAW_INT, 0x205 @display an int on LCD
.equ SWI_CLEAR_DISPLAY,0x206 @clear LCD

.equ SWI_DRAW_CHAR, 0x207 @display a char on LCD
-equ SWI_CLEAR_LINE, 0x208 @clear a line on LCD
-equ SWI_EXIT, Ox11 @terminate program

-.equ SWI_GetTicks, Oxé6d @get current time

.equ SEG_A, 0x80 @ patterns for 8 segment display
.equ SEG B, 0x40 @byte values for each segment
.equ SEG C, 0x20 @of the 8 segment display

.equ SEG_D, 0x08

.equ SEG_E, 0Ox04

.equ SEG_F, 0x02

.equ SEG_G, 0x01

.equ SEG_P, 0x10

-equ LEFT_LED, 0x02 @bit patterns for LED lights
.equRIGHT_LED, 0x01

.equ LEFT_BLACK_BUTTON,0x02 @bit patterns for black buttons
.equ RIGHT_BLACK_BUTTON, Ox01 @and for blue buttons
.equBLUE_KEY_ 00, 0x01 @button(0)

.equ BLUE_KEY_01, 0x02 @button(l)

.equ BLUE_KEY_02, 0x04 @button(2)

.equ BLUE_KEY_03, 0x08 @button(3)

.equ BLUE_KEY_04, 0x10 @button(4)

.equBLUE_KEY_05, 0x20 @button(5)

.equBLUE_KEY_ 06, 0x40 @button(6)

.equ BLUE_KEY_07, 0x80 @button(7)

-equBLUE_KEY_00, 1<<8 @button(8) - different way to set
.equBLUE_KEY_01, 1<<9 @button(9)

.equ BLUE_KEY_02,
-equ BLUE_KEY_O03,
-equ BLUE_KEY_04,
-equ BLUE_KEY_O05,
-equ BLUE_KEY_O06,
-equ BLUE_KEY_07,

1<<10 @button(10)
1<<11 @button(1l)
1<<12 @button(12)
1<<13 @button(13)
1<<14 @button(14)
1<<15 @button(15)

10.4 Example: Subroutine to implement a wait cycle with the 32-bit timer
@ wWait(Delay:r2) wait for r2 milliseconds

Wait:

stmfdsp!, {rO-ri,Ir}

33



ARMSim¢# User Guide

swi SWI_GetTicks

mov rl, rO @ R1: start time
WaitLoop:

swi SWI_GetTicks

subsr0, r0, ri @ RO: time since start

rsbltr0, ro, #0 @ fix unsigned subtract

cmp rO, r2

blt WaitLoop
WaitDone:

ldmfdsp!, {rO-rl,pc}

10.5 Example: Subroutine to check for an interval with a 15-bit timer (Embest Board)

The timer in ARMSim# is implemented using a 32-bit quantity and the current time (as number of ticks)
is accessed by using the SWI instruction with operand 0X6d (the corresponding EQU is set to be
SWI_GetTicks). It returns in RO the number of ticks in milliseconds. On the other hand, the timer on
the Embest board uses only a 15-bit quantity and this can cause a problem with rollover. Assume one
checks the time at a starting point T1 and then later at point T2, and one needs to test whether a certain
amount of time has passe. Ideally computing T2-T1 and comparing it to the desired interval is enough.
The range in ARMSim# with a 32-bit timer is between 0 and 232.1= 4,294,967,295. As milliseconds, this
gives a range of about 71,582 minutes, which is normally enough to ensure that one can keep checking
the intervals T2-T1 without T2 ever going out of range in a single program execution.

The range in the Embest board with a 15-bit timer is between 0 and 2!°-1 = 32,767, giving a range of only
32 seconds. When checking the interval T2-T1, there is no problem as long as T2>T1 and T2<32,767.
However it can happen that T1 is obtained close to the top of the range and T1 subsequently has a value
after the rollover, thus T2<TT1. It is not enough to flip the sign as the following examples show.

Let T1=1,000 and T2 =15,000. Then T2-T1 = 14,000 gives the correct answer for the interval. Subse-
quently let T1= 30,000 and the later T2 = 2,000 (afte the timer has rolled over). If one simply calculates T2-
T1=-28,000 or even tries to get its absolute value, the answer is incorrect. The value for the interval
should be: (32,767 - T1) + T2 = 32,767 -30,000 + 2,000 = 4,767, which represents the correct number of ticks
which passed between T1 and T2.

Two things need to be done for correct programming. First of all the timing value obtained in 32 bits in
ARMSim# should be “masked” to be only a 15 bit quantity, so that the code will work both in the simula-
tor and on the board. Secondly, the testing for the interval include a test for rollover.

.equ Secl, 1000 @ 1 seconds interval
.equ PointlSec, 100 @ 0.1 seconds interval
.equ EmbestTimerMask, Ox7fff @ 15 bit mask for timer values
-equ Topl5bitRange,0x0000FFff @(2n15) -1 = 32,767
.text
_start:
movre6,#0 @ counting the loops (nhot necessary)

Idrr8,=Topl5bitRange
Idrr7,=EmbestTimerMask
Idrr10,=PointlSec

SWISWI_GetTicks @Get current time T1

movrl,rO @ R1 is T1
andrl,rl,r7 @ T1 in 15 bits
RepeatTillTime:
addr6,r6,#1 @ count number of loops (not necessary)
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SWISWI_GetTicks @Get current time T2

movr2,r0 @ R2 1s T2
andr2,r2,r7 @ T2 1n 15 bits
cmpr2,rl @ 1s T2>T1?
bgesimpletime
subr9,r8,ril @ TIME= 32,676 - T1
addr9,r9,r2 @ + T2
balChecklInt
simpletime:
subr9,r2,rl @ TIME = T2-T1
ChecklInt:
cmpr9,rl0 @is TIME < interval?

bItRepeatTillTime
swiSWI_EXIT
-end

10.6 swiSWI_EXITExample: Using the SWI Instructions for a Plug-In (Embest Board View)
@ Demonstration of Embest S3CE40 development board view
@ ===== Assume the EQU declaration from previous examples
@Clear the board, clear the LCD screen
swi SWI_CLEAR DISPLAY
@Both LEDs off
mov rO0,#0
swi SWI_SETLED
@8-segment blank
mov rO,#0
swi SWI_SETSEGS8
@draw a message to the lcd screen on line#l, column 4
mov rO0,#4 @ column number
mov rl,#1 @ row number
Idr r2,=Welcome @ pointer to string
swi SWI_DRAW _STRING @ draw to the LCD screen
@display the letter H in 7segment display
Idr r0,=SEG B|SEG_C|SEG_G|SEG_E|SEG_F
swi SWI_SETSEGS8
@turn on LEFT led and turn off RIGHT led
mov rO,#LEFT_LED
swi SWI_SETLED
@draw a message to the lcd screen on line#2, column 4
mov rO0,#4 @ column number
mov rl,#2 @ row number
Idr r2,=LeftLED @ pointer to string
swi SWI_DRAW _STRING @ draw to the LCD screen
@wait for 3 second
Idr r3,=3000
BL Wwait
@turn on RIGHT led and turn off LEFT led
mov rO,#RIGHT_LED
swi SWI_SETLED
@draw a message to the lcd screen on line#2, column 4
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mov rO,#4 @ column number
mov rl,#2 @ row number
Idr r2,=RightLED @ pointer to string
swi SWI_DRAW _STRING @ draw to the LCD screen
@wait for 3 second
Idr r3,=3000
BL Wait
@turn on both led
mov rO,#(LEFT_LED|RIGHT_LED)
swi SWI_SETLED
@clear previous line 2
mov rO,#2
swi SWI_CLEAR_LINE
@draw a message to inform user to press a black button
mov rO,#6 @ column number
mov rl,#2 @ row number
Idr r2,=PressBlackL @ pointer to string
swi SWI_DRAW_STRING @ draw to the LCD screen
@wait for user to press a black button
mov ro0,#0
LB1:
swi SWI_CheckBlack @get button press into RO
cmp rO0,#0
beq LB1 @ if zero, no button pressed
cmp rO,#RIGHT_BLACK_BUTTON
bne LD1
Idr r0,=SEG_B|SEG_C|SEG_F @right button, show -|
swi SWI_SETSEGS8
mov rO,#RIGHT_LED @turn on right led
swi SWI_SETLED
bal NextButtons
LD1: @left black pressed

Idr r0,=SEG_G|SEG_E|]SEG_F @display |- on 8segment
swi SWI_SETSEGS8
mov rO,#LEFT LED @turn on LEFT led
swi SWI_SETLED
NextButtons:

@wait for 3 second

Idr r3,=3000

BL Wait
@Test the blue buttons 0-9 with prompting, then display
@number on 8-segment for 3 seconds. If >9, invalid.
@Draw a message to inform user to press a blue button

mov ro0,#2 @clear previous line 2
swi SWI_CLEAR LINE

mov rO,#6 @ column number

mov rl,#2 @ row number

Idr r2,=PressBlue @ pointer to string

swi SWI_DRAW_STRING @ draw to the LCD screen
mov r4,#16
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BLUELOOP:
@wait for user to press blue button

mov

BB1:
swi
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
beq
cmp
mov
swi
mov
mov
BL
bal

ONE:
mov
swi
mov
mov
BL

rO,#0

SWI_CheckBlue
ro,#0

BB1
rO,#BLUE_KEY_15
FIFTEEN
rO,#BLUE_KEY_14
FOURTEEN
ro,#BLUE_KEY_13
THIRTEEN
rO,#BLUE_KEY_12
TWELVE
rO,#BLUE_KEY_11
ELEVEN
ro,#BLUE_KEY_10
TEN
rO,#BLUE_KEY_09
NINE
rO,#BLUE_KEY_08
EIGHT
rO,#BLUE_KEY_07
SEVEN
rO,#BLUE_KEY_06
SIX
rO,#BLUE_KEY_05
FIVE
rO,#BLUE_KEY_04
FOUR
rO,#BLUE_KEY_03
THREE
rO,#BLUE_KEY_02
TWO
rO,#BLUE_KEY_0O1
ONE
rO,#BLUE_KEY_0O

ro,#5 @clear
SWI_CLEAR_LINE
ri,#0

ro,#0
Display8Segment
CKBLUELOOP
ro,#5 @clear
SWI_CLEAR_LINE
ri,#0

ro,#1

Display8Segment

@get button press into RO

@ if zero, no button pressed

previous line

previous line

ARMSim User Guide
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bal CKBLUELOOP

TWO:
mov rO,#5 @clear previous
swi SWI_CLEAR _LINE
mov rl1,#0
mov roO,#2
BL Display8Segment
bal CKBLUELOOP
THREE:
mov rO,#5 @clear previous
swi SWI_CLEAR_LINE
mov rl1,#0
mov rO0,#3
BL Display8Segment
bal CKBLUELOOP
FOUR:
mov rO,#5 @clear previous
swi SWI_CLEAR_LINE
mov rl1,#0
mov rO,#4
BL Display8Segment
bal CKBLUELOOP
FIVE:
mov rO,#5 @clear previous
swi SWI_CLEAR_LINE
mov rl1,#0
mov rO,#5
BL Display8Segment
bal CKBLUELOOP
SIX:
mov rO,#5 @clear previous
swi SWI_CLEAR _LINE
mov rl1,#0
mov rO,#6
BL Display8Segment
bal CKBLUELOOP
SEVEN:
mov rO,#5 @clear previous
swi SWI_CLEAR LINE
mov rl1,#0
mov rO,#7
BL Display8Segment
bal CKBLUELOOP
EIGHT:
mov rO0,#5 @clear previous
swi SWI_CLEAR LINE
mov rl1,#0
mov rO0,#8

BL Display8Segment
bal CKBLUELOOP
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NINE:
mov
SWi
mov
mov
BL
bal
TEN:
mov
SWi
mov
mov
Idr
SWi
mov
mov
BL
bal
ELEVEN:
mov
SWi
mov
mov
Idr
swi
mov
mov
BL
bal
TWELVE:
mov
SWi
mov
mov
Idr
swi
mov
mov
BL
bal

roO,#5 @clear previous line
SWI_CLEAR_LINE

rl,#0

ro,#9

Display8Segment

CKBLUELOOP

roO,#5 @clear previous line
SWI_CLEAR_LINE

ro,#6 @ column number
rl,#5 @ row number
r2,=InvBlue @ pointer to string

SWI_DRAW_STRING @ draw to the LCD screen
r1,#0

ro,#10 @ clear 8-segment
Display8Segment

CKBLUELOOP

roO,#5 @clear previous line
SWI_CLEAR_LINE

ro0,#6 @ column number
rl,#5 @ row number
r2,=InvBlue @ pointer to string

SWI_DRAW_STRING @ draw to the LCD screen
rl,#0

ro,#10 @ clear 8-segment
Display8Segment

CKBLUELOOP

ro,#5 @clear previous line
SWI_CLEAR_LINE

ro0,#6 @ column number
rl,#5 @ row number
r2,=InvBlue @ pointer to string

SWI_DRAW_STRING @ draw to the LCD screen
rl,#0

THIRTEEN:

mov
swi
mov
mov
Idr
SWi
mov
mov
BL

ro,#10 @ clear 8-segment
Display8Segment

CKBLUELOOP

ro,#5 @clear previous line
SWI_CLEAR_LINE

roO,#6 @ column number
rl,#5 @ row number
r2,=InvBlue @ pointer to string

SWI_DRAW_STRING @ draw to the LCD screen
rl,#0

ro,#10 @ clear 8-segment
Display8Segment

ARMSim User Guide
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bal CKBLUELOOP

FOURTEEN:
mov rO,#5 @clear previous line
swi SWI_CLEAR _LINE
mov rO,#6 @ column number
mov rl,#5 @ row number
Idr r2,=InvBlue @ pointer to string
swi SWI_DRAW_STRING @ draw to the LCD screen
mov rl1,#0
mov rO,#10 @ clear 8-segment

BL Display8Segment
bal CKBLUELOOP

FIFTEEN:
mov roO,#5 @clear previous line
swi SWI_CLEAR _LINE
mov rO0,#6 @ column number
mov rl,#5 @ row number
Idr r2,=InvBlue @ pointer to string
swi SWI_DRAW_STRING @ draw to the LCD screen
mov rl1,#0
mov rO,#10 @ clear 8-segment
BL Display8Segment

CKBLUELOOP:

mov rO0,#10 (@clear previous line
swi SWI_CLEAR_LINE

mov roO,#4 @clear previous line

swi SWI_CLEAR_LINE

mov rO0,#1 @ display number of tests
mov rl,#4

Idr r2,=TestBlue

swi  SWI_DRAW_STRING

mov ro0,#10

mov rl,#4

mov r2,r4

swi  SWI_DRAW_INT

subsr4,r4,#1

bne BLUELOOP @give only 15 tests
@Prepare to exit: Ist message and clear the board

@draw a message to the lcd screen on line#10, column 1

mov rO0,#1 @ column number
mov rl1,#10 @ row number
Idr r2,=Bye @ pointer to string

swi SWI_DRAW_STRING @ draw to the LCD screen
@Turn off both LED"s

Idr r0,=0

swi SWI_SETLED
@8-segment blank

mov rO0,#0

swi SWI_SETSEGS8

Idr r3,=2000 @delay a bit
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BL Wait
@Clear the LCD screen
swi  SWI_CLEAR_DISPLAY
swi SWI_EXIT @all done, exit
@ ===== Display8Segment (Number:RO; Point:R1l)
@ Displays the number 0-9 in RO on the 8-segment display
@ I'f R1 = 1, the point is also shown

Display8Segment:
stmfd sp!,{rO-r2,I1r}
Idr r2,=Digits
Idr ro, [r2,r0, Isl#2]
tst rl,#0x01 @if ri=1,
orrne rO,rQ0,#SEG_P @then show P
swi SWI1_SETSEGS
1dmfd sp!,{r0O-r2,pc}
@ ===== Wait(Delay:r3) wait for r3 milliseconds

@ Delays for the amount of time stored in r3 for a 15-bit timer
Wait:
stmfd sp!,{rO-r5,1r}

Idr r4 ,=0x00007FFF @mask for 15-bit timer
SwWi SWI_GetTicks @Get start time
and r1,r0,r4 @adjusted time to 15-bit
Wloop:
SWI SWI_GetTicks @Get current time
and r2,ro,r4 @adjusted time to 15-bit
cmp r2,rl
blt Roll @rolled above 15 bits
sub rs5,r2,rl @compute easy elapsed time
bal CmpLoop
Roll: sub r5,r4,rl @compute rolled elapsed time
add r5,r5,r2
CmpLoop:cmp r5,r3 @is elapsed time < delay?
blt Wloop @Continue with delay
Xwait:ldmfd sp!,{rO-r5,pc}
@ ... .., .., ., T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T T T T T T
.data
Welcome: asciz "Welcome to Board Testing"
LeftLED: asciz "LEFT light™
RightLED: asciz "RIGHT light"
PressBlackL: .asciz "Press a BLACK button"
Bye: .asciz "Bye for now."
Blank: .asciz """
Digits:

.word SEG_A|SEG_B|SEG_C|SEG_D|SEG_E|SEG_G @0
.word SEG_B|SEG_C @1

.word SEG_A|SEG_B|SEG_F|SEG_E|SEG D @2

.word SEG_A|SEG_B|SEG_F|SEG_C|SEG D @3

.word SEG_G|SEG_F|SEG_B|SEG_C @4

.word SEG_A|SEG_G|SEG_F|SEG_C|SEG D @5

.word SEG_A|SEG_G|SEG_F|SEG_E|SEG_D|SEG_C @6
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.word SEG_A|SEG_B|SEG_C @7

.word SEG_A|]SEG_B|SEG_C|SEG_D|SEG_E|SEG_F|SEG_G @8
-word SEG_A|SEG_B|SEG_F|SEG_G|SEG_C @9

-word 0O @Blank display

PressBlue: .asciz "Press a BLUE button 0-9 only - 15 tests"
InvBlue: .asciz "Invalid blue button - try again”
TestBlue: .asciz "Tests ="

.end
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